#5669 closed enhancement (fixed)

Split FIdUseExp into InstAccessExp and FAccessExp

Reported by: molsson Owned by: molsson
Priority: major Milestone:
Component: Modelica/FrontEnd Version: trunk
Keywords: Cc:

Description

FIdUseExp should be replaced with two new classes, one for the instance tree and one for the flat tree. These classes should have a common abstract super class.

Change History (25)

comment:1 Changed 16 months ago by molsson

Status: assignedaccepted

comment:2 Changed 16 months ago by molsson

changeset:11515
Merging trunk to dev-performance.

comment:3 Changed 16 months ago by molsson

changeset:11519
Created InstAccessExp and FAccessExp.

comment:4 Changed 16 months ago by molsson

changeset:11520
Fixed error caused by r11519.

comment:5 Changed 16 months ago by molsson

changeset:11521
Refactored FIdUseExp.createNode().

comment:6 Changed 16 months ago by molsson

changeset:11523
Fixed error relating to CasADi and FIdUseExp.

comment:7 Changed 16 months ago by molsson

changeset:11525
Refactored FIdUseExpLookupVisitor.

comment:8 Changed 16 months ago by molsson

changeset:11526
Fixed problem with CasADi and FAccess.

comment:9 Changed 16 months ago by molsson

changeset:11527
Moved some minor attributes from Inst/FAccess to Inst/FAccessExp.

comment:10 Changed 16 months ago by molsson

changeset:11528
Renamed ConnectionSetEntry.createFIdUseExp() to createFAccessExp().

comment:11 Changed 16 months ago by molsson

changeset:11529
Changed names of some variables from fqn to access.

comment:12 Changed 16 months ago by molsson

changeset:11530
Renamed createUseExp() to createAccessExp().

comment:13 Changed 16 months ago by molsson

changeset:11531
Renamed FIdUseExp to CommonAccessExp.

Last edited 16 months ago by molsson (previous) (diff)

comment:14 Changed 16 months ago by molsson

changeset:11532
Fixed mistakes in r11531.

comment:15 Changed 16 months ago by molsson

changeset:11533
Renamed FIdTempExp to FTempAccessExp.

comment:16 Changed 16 months ago by molsson

changeset:11535
Replaced AccessExp casts with function calls.

comment:17 Changed 16 months ago by molsson

changeset:11537
Fixed error caused by r11519.

comment:18 Changed 16 months ago by molsson

changeset:11539
Minor refactorization of DependencyVariableEvaluator.createUnknownCValue().

comment:19 Changed 16 months ago by molsson

changeset:11540
Fixed error in r11539.

comment:20 Changed 16 months ago by molsson

changeset:11542
Merged trunk to dev-performance.

comment:21 Changed 16 months ago by molsson

changeset:11553
Merged r11543-r11546 to dev-performance.

comment:22 Changed 16 months ago by molsson

changeset:11558
Added file missing from r11553.

comment:23 Changed 15 months ago by molsson

changeset:11671
Merging trunk to dev-performance.

comment:24 Changed 15 months ago by molsson

changeset:11676
Merging dev-performance to trunk.

comment:25 Changed 15 months ago by molsson

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.