Opened 3 years ago

Last modified 20 months ago

#5363 reopened defect

Code generation for division with nonzero literals

Reported by: Jonathan Kämpe Owned by: Jonathan Kämpe
Priority: major Milestone:
Component: Modelica/FrontEnd Version: trunk
Keywords: Cc:

Description

Code generation for division could be improved by not generating function calls when the divider is a non zero literal.

Change History (6)

comment:1 Changed 3 years ago by Jonathan Kämpe

changeset:9893

Improved code generation for division. Also fixed a bug for library search paths in GccCompilerDelegator.

comment:2 Changed 2 years ago by Jonathan Kämpe

changeset:9894

Reverting r9893 since it broke some tests

comment:3 Changed 2 years ago by Zimon Kuhs

Resolution: fixed
Status: assignedclosed

r10014

  • Changed printing of literal integers in C code generation. They are now printed as reals, except when used as for-indices.
  • Removed the generated C macro AD_WRAP_LITERAL().
Last edited 2 years ago by Zimon Kuhs (previous) (diff)

comment:4 Changed 2 years ago by Zimon Kuhs

Resolution: fixed
Status: closedreopened

r10030

Reverted r10014 as it caused regression.

comment:5 Changed 2 years ago by Christian Andersson

Milestone: 2.1.x2.2.x

comment:6 Changed 20 months ago by Christian Andersson

Milestone: 2.2.x

Ticket retargeted after milestone closed

Note: See TracTickets for help on using tickets.