Opened 4 years ago

Closed 2 years ago

#4476 closed enhancement (fixed)

Simplification of smooth constant

Reported by: Christian Andersson Owned by: jsten
Priority: major Milestone: Pending
Component: Modelica/MiddleEnd Version: trunk
Keywords: #4093. Cc:

Description

If the smooth operator only contains a constant expression, the smooth operator should be removed, i.e.:

smooth(0, 1.0);

should be equal to one.

This is a part of #4093.

Change History (5)

comment:1 Changed 4 years ago by Christian Andersson

Also, smooth(*, x) should be simplified.

comment:2 Changed 4 years ago by jsten

Milestone: 1.16.x1.17.x

This is possible and should be handled by variability propagation. The problem is that the original model had more complex structure which resulted in a known variability propagation bug.

comment:3 Changed 4 years ago by Tove Bergdahl

Milestone: 1.17Pending

comment:4 Changed 3 years ago by Christian Andersson

changeset:9072

Fixed symbolic simplifications of smooth and noevent for expressions of type noEvent(x) and smooth(0, x). Related to ticket:4476 and ticket:4420

comment:5 Changed 2 years ago by Christian Andersson

Resolution: fixed
Status: newclosed

This has been fixed as of changeset:9072

Note: See TracTickets for help on using tickets.