Opened 6 years ago

Last modified 2 days ago

#3547 reopened defect

Precision in constant evaluation of external functions

Reported by: Jonathan Kämpe Owned by: Jonathan Kämpe
Priority: major Milestone: Pending
Component: Modelica/FrontEnd Version: trunk
Keywords: Cc:

Description

When evaluating constant external functions (#2963) some precision is lost when serializing doubles for communication between the compiler and the subprocess evaluating the function. For example in the test "testDGELSX" in test_extFunctions.py there is a small difference (14th decimal) in the result. This could perhaps be amended by using some binary/hex representation when serializing.

Change History (2)

comment:1 Changed 2 weeks ago by Jesper Mattsson

Resolution: duplicate
Status: newclosed

Duplicate of #5881.

comment:2 in reply to:  1 Changed 2 days ago by Jesper Mattsson

Resolution: duplicate
Status: closedreopened

Replying to Jesper Mattsson:

Duplicate of #5881.

This was in error, fixing #5881 did not solve this problem.

Note: See TracTickets for help on using tickets.