Opened 6 years ago

Closed 6 years ago

#3110 closed defect (fixed)

Assert problem in Engine1b

Reported by: Christian Andersson Owned by: Christian Andersson
Priority: major Milestone: 1.12
Component: FMU/JMU runtime Version: trunk
Keywords: #2585. Cc:

Description

During a simulation of the MBS model Engine1b we currently trigger an assert error that makes the simulation fail. The assert comes from the gasForce component and is defined as,

assert(gasForce.s_rel <= gasForce.L + 1.0E-12, " flange_b.s - flange_a.s (= " + String(gasForce.s_rel, 14) + ") <= L (= " + String(gasForce.L, 14) + ") required for GasForce component.\n" + "Most likely, parameter L is not correct.");

and triggers during the event localization,

flange_b.s - flange_a.s (= 0.35000000000288) <= L (= 0.35) required for GasForce component.
Most likely, parameter L is not correct.

The problem is as I see it that the assert is set too "tight" and for a successful simulation requires a very high tolerance. This is because gasForce.s_rel actually becomes gasForce.L and only tolerating a deviation of 1e-12 is strict.

The model fails to simulate using our default tolerances which is 1e-4 RTOL and 1e-6 ATOL. Increasing the tolerances result in a successful simulation.

We need to discuss how to handle it.

This is needed for #2585.

Change History (2)

comment:1 Changed 6 years ago by Jesper Mattsson

Owner: set to Christian Andersson
Status: newassigned

comment:2 Changed 6 years ago by Christian Andersson

Resolution: fixed
Status: assignedclosed

This has been fixed as of changeset:5668

Note: See TracTickets for help on using tickets.